пятница, 26 октября 2018 г.

Мини интернет BGP OSPF EIGRP

Мини интернет в эмуляторе сети GNS3.

P.S Автор не является профессиональным сетевиком, сохранил чтобы помнить как настраивать динамическую маршрутизацию.




==========================================================

mini internet


==========================
BGP OSPF EIGRP
==========================
Office = R11

interface FastEthernet0/0
 ip address 97.22.45.2 255.255.255.248
 ip nat outside
 ip virtual-reassembly in
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto

!
ip nat pool TEST 97.22.45.2 97.22.45.2 netmask 255.255.255.248
ip nat inside source list office pool TEST overload
ip route 0.0.0.0 0.0.0.0 97.22.45.1
!
ip access-list extended office
 permit ip 192.168.1.0 0.0.0.255 any
 permit icmp any any

==============================================================================================
R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 165.95.31.66 255.255.255.240
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 178.55.22.1 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 router-id 127.0.0.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 66.15.20.0 0.0.0.7 area 0
 network 82.200.245.0 0.0.0.7 area 0
 network 97.22.45.0 0.0.0.7 area 0
 network 165.95.31.64 0.0.0.15 area 0
 network 178.55.22.0 0.0.0.7 area 0
 network 185.15.11.0 0.0.0.7 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 100
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 2.2.2.2 peer-group BGP_PEERS
 neighbor 3.3.3.3 peer-group BGP_PEERS
 neighbor 9.9.9.9 peer-group BGP_PEERS
 no auto-summary
!
================================================================================
R2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 178.55.22.2 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 185.15.11.2 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 97.22.45.1 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 router-id 127.0.0.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 82.200.245.0 0.0.0.7 area 0
 network 97.22.45.0 0.0.0.7 area 0
 network 165.95.31.64 0.0.0.15 area 0
 network 178.55.22.0 0.0.0.7 area 0
 network 185.15.11.0 0.0.0.7 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 100
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 1.1.1.1 peer-group BGP_PEERS
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 9.9.9.9 peer-group BGP_PEERS
 no auto-summary
!
===================================================================
R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 165.95.31.65 255.255.255.240
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 82.200.245.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 22.11.3.1 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 router-id 127.0.0.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 66.15.20.0 0.0.0.7 area 0
 network 82.200.245.0 0.0.0.7 area 0
 network 97.22.45.0 0.0.0.7 area 0
 network 165.95.31.64 0.0.0.15 area 0
 network 178.55.22.0 0.0.0.7 area 0
 network 185.15.11.0 0.0.0.7 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 22.11.3.0 mask 255.255.255.252
 redistribute ospf 1
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 100
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 1.1.1.1 peer-group BGP_PEERS
 neighbor 2.2.2.2 peer-group BGP_PEERS
 neighbor 4.4.4.4 peer-group BGP_PEERS
 neighbor 9.9.9.9 peer-group BGP_PEERS
 neighbor 22.11.3.2 remote-as 200
 no auto-summary
!
==================================================================
R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 66.15.20.2 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 82.200.245.2 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 router-id 127.0.0.4
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 66.15.20.0 0.0.0.7 area 0
 network 82.200.245.0 0.0.0.7 area 0
 network 97.22.45.0 0.0.0.7 area 0
 network 165.95.31.64 0.0.0.15 area 0
 network 178.55.22.0 0.0.0.7 area 0
 network 185.15.11.0 0.0.0.7 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 100
 no auto-summary
!
=======================================================================
R5
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 212.154.140.1 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 178.88.164.18 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 22.11.3.2 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 10
 network 5.5.5.5 0.0.0.0
 network 73.15.30.0 0.0.0.7
 network 112.15.1.0 0.0.0.7
 network 146.82.61.0 0.0.0.7
 network 178.88.164.16 0.0.0.7
 network 212.154.140.0 0.0.0.7
 no auto-summary
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 22.11.3.0 mask 255.255.255.252
 redistribute eigrp 10
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 200
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 6.6.6.6 peer-group BGP_PEERS
 neighbor 7.7.7.7 peer-group BGP_PEERS
 neighbor 8.8.8.8 peer-group BGP_PEERS
 neighbor 10.10.10.10 peer-group BGP_PEERS
 neighbor 22.11.3.1 remote-as 100
 no auto-summary
!
ip classless
!
no ip http server
no ip http secure-server
!
ip access-list extended FOR_BGP
 permit ip 212.154.140.0 0.0.0.7 any
 permit ip host 6.6.6.6 any
 permit ip host 5.5.5.5 any
!
=============================================================
R6

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 212.154.140.2 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 112.15.1.1 255.255.255.248
 duplex auto
 speed auto
!
router eigrp 10
 network 6.6.6.6 0.0.0.0
 network 73.15.30.0 0.0.0.7
 network 112.15.1.0 0.0.0.7
 network 146.82.61.0 0.0.0.7
 network 178.88.164.16 0.0.0.7
 network 212.154.140.0 0.0.0.7
 no auto-summary
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 5.5.5.5 mask 255.255.255.255
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 200
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 5.5.5.5 peer-group BGP_PEERS
 neighbor 7.7.7.7 peer-group BGP_PEERS
 neighbor 8.8.8.8 peer-group BGP_PEERS
 neighbor 10.10.10.10 peer-group BGP_PEERS
 no auto-summary
!
=======================================================================
R7

interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
 ip address 73.15.30.1 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 178.88.164.17 255.255.255.248
 duplex auto
 speed auto
!
router eigrp 10
 network 7.7.7.7 0.0.0.0
 network 73.15.30.0 0.0.0.7
 network 112.15.1.0 0.0.0.7
 network 146.82.61.0 0.0.0.7
 network 178.88.164.16 0.0.0.7
 network 212.154.140.0 0.0.0.7
 no auto-summary
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 200
 neighbor BGP_PEERS next-hop-self
 neighbor 5.5.5.5 remote-as 200
 neighbor 6.6.6.6 peer-group BGP_PEERS
 neighbor 8.8.8.8 peer-group BGP_PEERS
 neighbor 10.10.10.10 peer-group BGP_PEERS
 no auto-summary
!
==================================================================
R8

interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
 ip address 146.82.61.2 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 112.15.1.2 255.255.255.248
 duplex auto
 speed auto
!
router eigrp 10
 network 8.8.8.8 0.0.0.0
 network 73.15.30.0 0.0.0.7
 network 112.15.1.0 0.0.0.7
 network 146.82.61.0 0.0.0.7
 network 178.88.164.16 0.0.0.7
 network 212.154.140.0 0.0.0.7
 no auto-summary
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 200
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 5.5.5.5 remote-as 200
 neighbor 6.6.6.6 peer-group BGP_PEERS
 neighbor 7.7.7.7 peer-group BGP_PEERS
 neighbor 10.10.10.10 peer-group BGP_PEERS
 no auto-summary
!
==============================================================
R9

interface Loopback0
 ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
 ip address 185.15.11.1 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 66.15.20.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 185.69.4.2 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 router-id 127.0.0.5
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 9.9.9.9 0.0.0.0 area 0
 network 66.15.20.0 0.0.0.7 area 0
 network 82.200.245.0 0.0.0.7 area 0
 network 97.22.45.0 0.0.0.7 area 0
 network 165.95.31.64 0.0.0.15 area 0
 network 178.55.22.0 0.0.0.7 area 0
 network 185.15.11.0 0.0.0.7 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 100
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 1.1.1.1 peer-group BGP_PEERS
 neighbor 2.2.2.2 peer-group BGP_PEERS
 neighbor 3.3.3.3 remote-as 100
 neighbor 4.4.4.4 peer-group BGP_PEERS
 neighbor 185.69.4.1 remote-as 300
 no auto-summary
!
================================================================
R10

interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
 ip address 73.15.30.2 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 146.82.61.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 52.2.4.2 255.255.255.248
 duplex auto
 speed auto
!
router eigrp 10
 network 10.10.10.10 0.0.0.0
 network 73.15.30.0 0.0.0.7
 network 112.15.1.0 0.0.0.7
 network 146.82.61.0 0.0.0.7
 network 178.88.164.16 0.0.0.7
 network 212.154.140.0 0.0.0.7
 no auto-summary
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 200
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 5.5.5.5 remote-as 200
 neighbor 6.6.6.6 peer-group BGP_PEERS
 neighbor 7.7.7.7 peer-group BGP_PEERS
 neighbor 8.8.8.8 peer-group BGP_PEERS
 neighbor 52.2.4.1 remote-as 300
 no auto-summary
!
==================================================================
R12

interface Loopback0
 ip address 12.12.12.12 255.255.255.255
!
interface FastEthernet0/0
 ip address 185.69.4.1 255.255.255.248
 duplex full
!
interface FastEthernet1/0
 ip address 193.24.3.3 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 98.15.6.4 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 network 12.12.12.12 0.0.0.0 area 1
 network 14.88.97.0 0.0.0.7 area 1
 network 77.63.5.0 0.0.0.7 area 1
 network 98.15.6.0 0.0.0.7 area 1
 network 193.24.3.0 0.0.0.7 area 1
!
router bgp 300
 bgp log-neighbor-changes
 network 185.69.4.0 mask 255.255.255.248
 redistribute ospf 1
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 300
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 13.13.13.13 peer-group BGP_PEERS
 neighbor 14.14.14.14 peer-group BGP_PEERS
 neighbor 15.15.15.15 peer-group BGP_PEERS
 neighbor 185.69.4.2 remote-as 100
!
===================================================================
R13

interface Loopback0
 ip address 13.13.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 52.2.4.1 255.255.255.248
 duplex half
!
interface FastEthernet1/0
 ip address 77.63.5.1 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 98.15.6.5 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 network 13.13.13.13 0.0.0.0 area 1
 network 14.88.97.0 0.0.0.7 area 1
 network 77.63.5.0 0.0.0.7 area 1
 network 98.15.6.0 0.0.0.7 area 1
 network 193.24.3.0 0.0.0.7 area 1
!
router bgp 300
 bgp log-neighbor-changes
 network 52.2.4.0 mask 255.255.255.248
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 300
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 12.12.12.12 peer-group BGP_PEERS
 neighbor 14.14.14.14 peer-group BGP_PEERS
 neighbor 15.15.15.15 peer-group BGP_PEERS
 neighbor 52.2.4.2 remote-as 200
!
======================================================================
R14

interface Loopback0
 ip address 14.14.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 193.24.3.4 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 14.88.97.1 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 14.14.14.14 0.0.0.0 area 1
 network 14.88.97.0 0.0.0.7 area 1
 network 77.63.5.0 0.0.0.7 area 1
 network 98.15.6.0 0.0.0.7 area 1
 network 193.24.3.0 0.0.0.7 area 1
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 300
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 12.12.12.12 peer-group BGP_PEERS
 neighbor 13.13.13.13 peer-group BGP_PEERS
 neighbor 15.15.15.15 peer-group BGP_PEERS
 no auto-summary
!
=============================================================================
R15

interface Loopback0
 ip address 15.15.15.15 255.255.255.255
!
interface FastEthernet0/0
 ip address 77.63.5.2 255.255.255.248
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 14.88.97.2 255.255.255.248
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 14.88.97.0 0.0.0.7 area 1
 network 15.15.15.15 0.0.0.0 area 1
 network 77.63.5.0 0.0.0.7 area 1
 network 98.15.6.0 0.0.0.7 area 1
 network 193.24.3.0 0.0.0.7 area 1
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 neighbor BGP_PEERS peer-group
 neighbor BGP_PEERS remote-as 300
 neighbor BGP_PEERS update-source Loopback0
 neighbor BGP_PEERS next-hop-self
 neighbor 12.12.12.12 peer-group BGP_PEERS
 neighbor 13.13.13.13 peer-group BGP_PEERS
 neighbor 14.14.14.14 peer-group BGP_PEERS
 no auto-summary
!
=======================================================================






Комментариев нет:

Отправить комментарий